Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Sep 01, 2016 - 19:27 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted almost 2 years ago. Sep 01, 2016 - 19:21 EDT