Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #SmitePC
Posted 3 months ago. Apr 18, 2017 - 07:42 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Apr 18, 2017 - 07:27 EDT
This incident affected: Smite PC - North America / Europe.