Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite PC suffered from a momentary issue with Steam logins / sales; everything is normalizing.
Posted over 1 year ago. Mar 22, 2016 - 19:55 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted over 1 year ago. Mar 22, 2016 - 19:41 EDT