Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #smitepc
Posted 4 months ago. Mar 01, 2017 - 17:20 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Mar 01, 2017 - 17:12 EST
This incident affected: Smite PC - North America / Europe.