Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue has been identified and was resolved.
Posted 20 days ago. Sep 29, 2017 - 01:20 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 20 days ago. Sep 29, 2017 - 01:13 EDT
This incident affected: Smite PC - North America / Europe.