Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved #PaladinsPC
Posted 7 months ago. May 09, 2017 - 13:52 EDT
Identified
The issue has been identified and a fix is being implemented. #PaladinsPC
Posted 7 months ago. May 09, 2017 - 13:08 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 7 months ago. May 09, 2017 - 13:07 EDT