Hand of the Gods PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
The emergency restart for #HotG #PC has been completed.
Posted 9 days ago. Feb 13, 2018 - 18:22 EST
Identified
We are performing an emergency restart for #HotG #PC. The game will be back up shortly.
Posted 9 days ago. Feb 13, 2018 - 18:09 EST
This incident affected: Hand of the Gods PC.