Smite Xbox Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE XBOX has been restarted but there are still XBox-Live issues from Microsoft
Posted about 1 year ago. Feb 23, 2016 - 09:31 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 year ago. Feb 23, 2016 - 08:14 EST
Investigating
We will be restarting Smite Xbox to fix an issue with purchases, in 10 min #smite
Posted about 1 year ago. Feb 23, 2016 - 07:54 EST