Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. May 18, 2017 - 15:12 EDT
Identified
We are looking into issues with Paladins PC.
Posted about 1 month ago. May 18, 2017 - 14:51 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 1 month ago. May 18, 2017 - 14:48 EDT
This incident affected: Paladins PC.