Smite PS4 Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue with #Smite #PS4 has been resolved.
Posted 18 days ago. Nov 03, 2017 - 19:06 EDT
Monitoring
The emergency restart for #Smite #PS4 has been completed. We are monitoring the results.
Posted 18 days ago. Nov 03, 2017 - 18:37 EDT
Identified
We are performing an emergency restart of #Smite #PS4. The game will be back up shortly.
Posted 18 days ago. Nov 03, 2017 - 18:17 EDT
This incident affected: Smite PS4 - North America / Europe.