Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Smite #Xbox has been resolved
Posted 19 days ago. Aug 02, 2017 - 17:33 EDT
Monitoring
The emergency restart for #Smite #Xbox has been completed. We are monitoring the results.
Posted 19 days ago. Aug 02, 2017 - 17:21 EDT
Identified
We are performing an emergency restart for #Smite #Xbox. The game will be back up shortly.
Posted 19 days ago. Aug 02, 2017 - 17:07 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 19 days ago. Aug 02, 2017 - 16:55 EDT
This incident affected: Smite Xbox - North America / Europe.