Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved.#smite
Posted over 1 year ago. Jul 18, 2016 - 11:46 EDT
Update
We are performing an emergency restart on Smite PC#smite
Posted over 1 year ago. Jul 18, 2016 - 11:27 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted over 1 year ago. Jul 18, 2016 - 11:24 EDT