Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This issues has been resolved.
#smite #ps4
Posted over 1 year ago. Apr 18, 2016 - 23:16 EDT
Identified
Some of our instances have had connectivity issues and we are working to resolve the issue.
#Smite #PS4
Posted over 1 year ago. Apr 18, 2016 - 23:05 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted over 1 year ago. Apr 18, 2016 - 22:50 EDT