Smite PC and Paladins PC - Login issues related to Steam
Incident Report for Hi-Rez Studios, Inc
Resolved
Steam logins issues for #SMITE PC and #Paladins PC have been resolved; logins are returning to normal levels.
Posted 6 months ago. Oct 18, 2016 - 19:51 EDT
Monitoring
Steam service has maintenance window every Tuesday; and we are seeing impacts to logins for both #SMITE PC and #Paladins PC; we are monitoring the situation and it should resolve itself shortly.
Posted 6 months ago. Oct 18, 2016 - 19:40 EDT