Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted over 1 year ago. Apr 23, 2016 - 16:14 EDT
Identified
Smite PC Steam users may be experiencing difficulty logging in, Steam is currently having issues
http://downdetector.com/status/steam #smite
Posted over 1 year ago. Apr 23, 2016 - 15:57 EDT
Update
Investigating: We are currently investigating this Smite PC issue#smite
Posted over 1 year ago. Apr 23, 2016 - 15:52 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted over 1 year ago. Apr 23, 2016 - 15:48 EDT