Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite #PC issue has been resolved
Posted 5 months ago. Jul 27, 2017 - 06:45 EDT
Monitoring
Services are recovering and we are currently monitoring #Smite #PC
Posted 5 months ago. Jul 27, 2017 - 06:33 EDT
Identified
We have identified an issue with #Smite #PC and are working on bringing services back to normal
Posted 5 months ago. Jul 27, 2017 - 06:12 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 5 months ago. Jul 27, 2017 - 05:59 EDT
This incident affected: Smite PC - North America / Europe.