Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 20 days ago. Jul 02, 2017 - 11:39 EDT
Monitoring
We have implemented a fix for the issue in #Smite #PS4 and are monitoring the results.
Posted 20 days ago. Jul 02, 2017 - 11:31 EDT
Identified
We have identified an issue with #Smite #PS4 and are actively working to resolve.
Posted 20 days ago. Jul 02, 2017 - 10:54 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 20 days ago. Jul 02, 2017 - 10:46 EDT
This incident affected: Smite PS4 - North America / Europe.