Data Center Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
#smite #paladins We believe the data center issues of the last 24 hours have been resolved, all games are up
Posted about 1 year ago. Jun 25, 2016 - 18:05 EDT
Update
Soon we will be performing server maintenance's on all games and platforms, we will update when we have a closer time#smite #paladins #tribes
Posted about 1 year ago. Jun 25, 2016 - 13:21 EDT
Update
#smite #paladins Hirez data center issues continue. We have changes planned this morning to hopefully improve.
Posted about 1 year ago. Jun 25, 2016 - 08:52 EDT
Update
We are still experiencing issues but are working to resolve them as quickly as possible#smite #paladins #tribes
Posted over 1 year ago. Jun 24, 2016 - 17:42 EDT
Investigating
We are currently having issues at our datacenter, we are working to resolve.#smite #paladins #tribes
Posted over 1 year ago. Jun 24, 2016 - 16:40 EDT