SMITE PC Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#SMITE PC: We have resolved the login issue; apologies for any inconvenience.
Posted almost 2 years ago. Oct 19, 2015 - 19:28 EDT
Investigating
#SMITE PC - we are seeing drop in Logins; currently investigating...
Posted almost 2 years ago. Oct 19, 2015 - 17:30 EDT