Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 07, 2017 - 12:37 EDT
Monitoring
Logins have been resumed. We are monitoring the environment.
Posted 4 months ago. Apr 07, 2017 - 12:23 EDT
Update
Investigating: We are currently investigating this Paladins PC issue. #PaladinsPC
Posted 4 months ago. Apr 07, 2017 - 12:16 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 4 months ago. Apr 07, 2017 - 10:38 EDT
This incident affected: Paladins PC.