Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 29, 2017 - 08:54 EDT
Monitoring
We are currently monitoring Smite PC. #SMITE PC
Posted about 2 months ago. Jan 29, 2017 - 08:49 EDT
Update
We are looking into issues with Smite PC. #SMITE PC
Posted about 2 months ago. Jan 29, 2017 - 08:32 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. Jan 29, 2017 - 08:27 EDT
This incident affected: Smite PC - North America / Europe.