Pausing Logins On Paladins PC For A Few Moments
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved. #PaladinsPC
Posted 3 months ago. May 17, 2017 - 15:17 EDT
Update
We have resumed logins on Paladins PC #PaladinsPC
Posted 3 months ago. May 17, 2017 - 15:16 EDT
Investigating
We Will Be Pausing Logins On Paladins PC For A Few Moments #PaladinsPC
Posted 3 months ago. May 17, 2017 - 14:57 EDT
This incident affected: Paladins PC.