Smite PC Match Manager Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This #Smite #PC incident has been resolved.
Posted 6 days ago. Jul 10, 2018 - 13:05 EDT
Monitoring
#Smite #PC logins have resumed. We are continuing to monitor.
Posted 6 days ago. Jul 10, 2018 - 12:34 EDT
Identified
We have identified an issue with #Smite #PC Match Manager and have temporarily limited logins.
Posted 6 days ago. Jul 10, 2018 - 12:32 EDT
This incident affected: Smite (Smite PC).