Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with #SMITE #XBOX have been resolved.
Posted about 1 month ago. May 10, 2017 - 22:55 EDT
Identified
We are currently looking into issues with #SMITE #XBOX
Posted about 1 month ago. May 10, 2017 - 22:35 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 month ago. May 10, 2017 - 22:32 EDT
This incident affected: Smite Xbox - North America / Europe.