Pausing logins paladins pc
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins for #Paladins #PC have resumed.
Posted about 1 month ago. May 18, 2017 - 17:07 EDT
Investigating
We will be pausing logins temporarily for #Paladins on #PC.
Posted about 1 month ago. May 18, 2017 - 16:45 EDT
This incident affected: Paladins PC.