Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #PaladinsPC
Posted Sep 18, 2017 - 07:05 EDT
Update
We are still investigating the issue with #Paladins #PC.
Posted Sep 18, 2017 - 06:15 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Sep 18, 2017 - 04:06 EDT
This incident affected: Paladins (Paladins PC).