Smite PC Connectivity Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Sep 26, 2016 - 21:25 EDT
Monitoring
We are continuing to monitor this issue. #Smite
Posted 8 months ago. Sep 26, 2016 - 21:05 EDT
Identified
We are aware of the recent connectivity issues effecting #Smite #PC.
We are working to resolve this issue.
Sorry for the inconvenience.
Posted 8 months ago. Sep 26, 2016 - 20:51 EDT