Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This Hirez Games incident has been resolved #Hirez
Posted 6 months ago. Mar 18, 2017 - 06:35 EDT
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 6 months ago. Mar 18, 2017 - 05:38 EDT