Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Connectivity issue resolved; all #HiRez games returning to normal; apologies for the inconvenience; #SMITE #Tribes #Paladins
Posted 12 months ago. May 03, 2016 - 13:46 EDT
Identified
We are experiencing a connectivity issue and all #HiRez games are impacted, #SMITE #Tribes #Paladins; services are returning to normal.
Posted 12 months ago. May 03, 2016 - 13:39 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted 12 months ago. May 03, 2016 - 13:34 EDT