Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 5 months ago. May 06, 2017 - 12:09 EDT
Monitoring
We are recovering and monitoring Paladins PC.
Posted 5 months ago. May 06, 2017 - 11:50 EDT
Identified
We are currently looking into issues with Paladins PC.
Posted 5 months ago. May 06, 2017 - 11:46 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 5 months ago. May 06, 2017 - 11:37 EDT
This incident affected: Paladins PC.