Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This paladins incident has been resolved.#paladins
Posted 11 months ago. Nov 12, 2016 - 10:55 EST
Identified
We are pausing logins for a few moments to restart a component in the game, sorry for the inconviencance #paladins
Posted 11 months ago. Nov 12, 2016 - 10:39 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 11 months ago. Nov 12, 2016 - 10:32 EST