Smite Xbox Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart Of Smite XBOX is complete#smite
Posted 9 months ago. Jun 23, 2016 - 04:14 EDT
Investigating
We are restarting Smite XBOX now#smite
Posted 9 months ago. Jun 23, 2016 - 04:07 EDT