Paladins PC Limiting Logins
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 22, 2017 - 09:34 EDT
Monitoring
We are currently limiting logins as we look into issues with Paladins PC.
Posted about 1 month ago. Feb 22, 2017 - 09:13 EDT
This incident affected: Paladins PC.