Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted about 1 year ago. Mar 29, 2016 - 19:54 EDT
Update
Steam users may still be experiencing issues#smite
Posted about 1 year ago. Mar 29, 2016 - 18:35 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Mar 29, 2016 - 18:32 EDT