Hirez Games possible issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Hirez Games incident has been resolved. #smite
Posted about 1 year ago. Jun 03, 2016 - 17:24 EDT
Monitoring
Monitoring: A fix has been implemented and we are monitoring the results#smite
Posted about 1 year ago. Jun 03, 2016 - 17:14 EDT
Update
We are going to restart Smite PC now #smite
Posted about 1 year ago. Jun 03, 2016 - 17:04 EDT
Update
Identified: The issue has been identified and a fix is being implemented#smite #paladins
Posted about 1 year ago. Jun 03, 2016 - 16:24 EDT
Identified
Identified: The issue has been identified and a fix is being implemented
Posted about 1 year ago. Jun 03, 2016 - 16:23 EDT
Investigating
Automated services have detected a possible problem our Atlanta servers and may affect all games. #SMITE #Tribes #Paladins. We are investigating.
Posted about 1 year ago. Jun 03, 2016 - 16:20 EDT