Website and Store Potential Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have identified and resolved the issue with the Hi-Rez Studios website as well as the #Smite and #Paladins #PC stores. We apologize for the inconvenience.
Posted 10 days ago. May 10, 2018 - 21:55 EDT
Investigating
We are investigating an issue with with Hi-Rez Studios website as well as the #Smite and #Paladins #PC stores.
Posted 10 days ago. May 10, 2018 - 21:42 EDT
This incident affected: Hi-Rez Public APIs.