Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have recovered from login issues on Paladins PC. #Paladins
Posted 9 months ago. Jan 16, 2017 - 16:43 EST
Update
We are investigating issues with Paladins PC. #Paladins
Posted 9 months ago. Jan 16, 2017 - 16:40 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 9 months ago. Jan 16, 2017 - 16:34 EST
This incident affected: Paladins PC.