Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Feb 21, 2021 - 11:34 EST
Investigating
We will be restarting the #RealmRoyale servers at 15:50 UTC and will be back up as soon as possible
Posted Feb 21, 2021 - 10:38 EST
This incident affected: Realm Royale (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).