Realm Royale Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jan 09, 2021 - 01:24 EST
Update
The emergency restart of #RealmRoyale is complete. We will continue to monitor.
Posted Jan 08, 2021 - 23:15 EST
Identified
We will be performing an emergency restart of #RealmRoyale. The game will be back shortly.
Posted Jan 08, 2021 - 22:29 EST
This incident affected: Realm Royale Reforged (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).