Smite Xbox Match Making
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 21 days ago. Sep 03, 2018 - 22:43 EDT
Monitoring
We were able to address the issue affecting matchmaking. Players should be able to login and queue for matches. We will continue to monitor for any further issues.
Posted 21 days ago. Sep 03, 2018 - 22:05 EDT
Investigating
We are currently investigating an issue that is affecting match making on #Smite #Xbox
Posted 21 days ago. Sep 03, 2018 - 21:33 EDT
This incident affected: Smite (Smite Xbox).