Smite Crossplay Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 19, 2020 - 21:42 EDT
Investigating
We are currently investigating this issue.
Posted May 19, 2020 - 20:53 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch).