Smite Crossplay login issue.
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Aug 26, 2020 - 19:22 EDT
Investigating
We are currently investigating this issue.
Posted Aug 26, 2020 - 16:58 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).