Smite Crossplay Matchmaking Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jul 03, 2021 - 05:40 EDT
Investigating
We are investigating an issue that is preventing matches from launching in #SMITE. We are working to return matchmaking services back to normal.
Posted Jul 03, 2021 - 05:16 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).