Smite Matchmaking Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jun 19, 2021 - 18:57 EDT
Update
Logins for #SMITE have resumed.
Posted Jun 19, 2021 - 16:23 EDT
Update
Queues are experiencing a backlog as players are trying to get back into matches. Queues may be temporarily unavailable. At this time we will be limiting logins to help mitigate this issue.
Posted Jun 19, 2021 - 16:09 EDT
Monitoring
Matchmaking and logins have resumed for #SMITE.
Posted Jun 19, 2021 - 15:46 EDT
Investigating
We have identified an issue that is preventing matches from launching in #SMITE. We are working to return matchmaking services back to normal. Logins will be limited in the meantime.
Posted Jun 19, 2021 - 15:40 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).