Hirez Websites
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 19 days ago. Jul 02, 2019 - 11:13 EDT
Investigating
We are currently looking into issues with www.smitegame.com and www.paladinsgame.com
Posted 19 days ago. Jul 02, 2019 - 10:05 EDT