Smite Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jun 12, 2022 - 18:24 EDT
Identified
We have identified the issue and have implemented a fix.
Posted Jun 12, 2022 - 18:00 EDT
Investigating
#Smite is currently experiencing some login issues and we are working on getting this corrected as soon as possible.
Posted Jun 12, 2022 - 17:45 EDT
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).