Realm Royale Game Service Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 03, 2021 - 19:36 EDT
Monitoring
All services for #RealmRoyale have resumed. We will continue to monitor.
Posted Apr 03, 2021 - 19:26 EDT
Investigating
We are investigating an issue that is affecting some of our game services for #Realm Royale.
Posted Apr 03, 2021 - 18:55 EDT
This incident affected: Realm Royale Reforged (Realm Royale PC, Realm Royale PS4, Realm Royale Xbox, Realm Royale Switch).