Smite Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jan 27, 2021 - 22:50 EST
Monitoring
Logins for #Smite have resumed. We will continue to monitor
Posted Jan 27, 2021 - 22:17 EST
Investigating
We are currently investigating an issue that is preventing some players from logging in on #Smite.
Posted Jan 27, 2021 - 22:07 EST
This incident affected: SMITE (SMITE PC, SMITE PS4, SMITE Xbox, SMITE Switch, SMITE Epic).