Rogue Company Login Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Oct 01, 2020 - 19:16 EDT
Update
The emergency restart of #RogueCompany is complete. We will continue to monitor for any further issues.
Posted Oct 01, 2020 - 17:25 EDT
Update
We will be performing and emergency restart of #RogueCompany. The game will be back soon.
Posted Oct 01, 2020 - 16:57 EDT
Update
We are limiting logins for #RogueCompany once again. We will update accordingly. Thank you for your patience.
Posted Oct 01, 2020 - 16:29 EDT
Monitoring
Logins for #RogueCompany have resumed. We will continue to monitor the state of the game for any further issues.
Posted Oct 01, 2020 - 16:23 EDT
Investigating
Logins for #RogueCompany have been limited temporarily to address issues with the live game. We will update the status with our progress accordingly.
Posted Oct 01, 2020 - 16:04 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).