Rogue Company Live Service Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted May 20, 2022 - 10:48 EDT
Monitoring
Live game services for #RogueCompany have resumed. We will continue to monitor.
Posted May 20, 2022 - 10:35 EDT
Investigating
We are investigating an issue that is affecting live game services for #RogueCompany
Posted May 20, 2022 - 10:17 EDT
This incident affected: Rogue Company (Rogue Company PC, Rogue Company PS4, Rogue Company Xbox, Rogue Company Switch, Rogue Company Epic).